🙇‍♀️벽 부수고 이동하기

N×M의 행렬로 표현되는 맵이 있다. 맵에서 0은 이동할 수 있는 곳을 나타내고, 1은 이동할수 없는 벽이 있는 곳을 나타낸다.
당신은 (1, 1)에서 (N, M)의 위치까지 이동하려 하는데, 이때 최단 경로로 이동하려 한다.

최단경로는 맵에서 가장 적은 개수의 칸을 지나는 경로를 말하는데, 이때 시작하는 칸과 끝나는 칸도 포함해서 센다.

만약에 이동하는 도중에 한 개의 벽을 부수고 이동하는 것이 좀 더 경로가 짧아진다면, 벽을 한 개 까지 부수고 이동하여도 된다.

한 칸에서 이동할 수 있는 칸은 상하좌우로 인접한 칸이다.

맵이 주어졌을 때, 최단 경로를 구해 내는 프로그램을 작성하시오.

입력
첫째 줄에 N(1 ≤ N ≤ 1,000), M(1 ≤ M ≤ 1,000)이 주어진다. 다음 N개의 줄에 M개의 숫자로 맵이 주어진다. 
(1, 1)과 (N, M)은 항상 0이라고 가정하자.

출력
첫째 줄에 최단 거리를 출력한다. 불가능할 때는 -1을 출력한다.

예제 입력 1 
6 4
0100
1110
1000
0000
0111
0000

예제 출력 1 
15

예제 입력 2 
4 4
0111
1111
1111
1110

예제 출력 2 
-1

🚀풀이

나는 이문제를 BFS를 모든 경우에 순회를 하여 풀려고 했다.
왜냐하면 N, M이 1000까지의 값을 가지니 시간 복잡도가 높아도 해결이 될 줄 알았다.

그런데 시간초과가 나왔다.
혼자 풀고싶어서 이리저리 많이 해봤는데 결국을 해결하지 못했다.

아래는 내가 만든 코드이다.

정답은 나오지만 시간초과로 틀린다.

#define _CRT_SECURE_NO_WARNINGS

#include <stdio.h>
#include <string.h>
#include <ctype.h>
#include<iostream>
#include <fstream>
#include <vector>
#include <algorithm>
#include <queue>
#include <map>

using namespace std;

int n, m, res = 123456789, path;
vector<vector<int>> board;
vector<vector<bool>> discovered;

struct Pos
{
	bool operator==(Pos& other)
	{
		return y == other.y && x == other.x;
	}

	bool operator!=(Pos& other)
	{
		return !(*this == other);
	}

	bool operator<(const Pos& other) const
	{
		if (y != other.y)
			return y < other.y;
		return x < other.x;
	}

	Pos operator+(Pos& other)
	{
		Pos ret;
		ret.y = y + other.y;
		ret.x = x + other.x;
		return ret;
	}

	Pos& operator+=(Pos& other)
	{
		y += other.y;
		x += other.x;
		return *this;
	}

	int y;
	int x;
};

Pos front[4] =
{
	Pos { -1, 0}, // UP
	Pos { 0, -1}, // LEFT
	Pos { 1, 0},  // DOWN
	Pos { 0, 1},  // RIGHT
};

// 1 : 벽
// 0 : 빈 공간
void setting()
{
	cin >> n >> m;
	board = vector<vector<int>>(n, vector<int>(m));
	discovered = vector<vector<bool>>(n, vector<bool>(m, false));
	string str;
	for (int i = 0; i < n; ++i)
	{
		cin >> str;
		for (int j = 0; j < m; ++j)
		{
			board[i][j] = str[j] - '0';
		}
	}
}

bool CanGo(Pos pos)
{
	if (pos.y < 0 || pos.x < 0)
		return false;
	if (pos.y > n - 1 || pos.x > m - 1)
		return false;
	return board[pos.y][pos.x] == 0; // 0이면 갈 수 있다.
}

void Bfs(Pos pos)
{
	map<Pos, Pos> parent;
	discovered = vector<vector<bool>>(n, vector<bool>(m, false));
	pos = { 0, 0 };
	path = 1;
	Pos dest = { n - 1, m - 1 };
	queue<Pos> q;
	q.push(pos);
	discovered[pos.y][pos.x] = true;
	parent[pos] = pos;

	while (q.empty() == false)
	{
		pos = q.front();
		q.pop();

		if (pos == dest)
			break;

		for (int dir = 0; dir < 4; ++dir)
		{
			Pos nextPos = pos + front[dir];
			if (CanGo(nextPos) == false)
				continue;
			if (discovered[nextPos.y][nextPos.x])
				continue;

			q.push(nextPos);
			discovered[nextPos.y][nextPos.x] = true;
			parent[nextPos] = pos;
		}
	}

	if (pos.y != n - 1 || pos.x != m - 1)
	{
		path = -1;
	}
	else
	{
		while (true)
		{
			if (pos == parent[pos])
				break;

			pos = parent[pos];
			path++;
		}

		if (path < res)
			res = path;
	}
}

int main() 
{
	ios_base::sync_with_stdio(false);
	cin.tie(NULL);
	cout.tie(NULL);
	//freopen("input.txt", "rt", stdin);

	Pos pos = { 0, 0 };
	setting();

	Bfs(pos);

	for (int y = 0; y < n; ++y)
	{
		for (int x = 0; x < m; ++x)
		{
			if (board[y][x] == 1)
			{
				board[y][x] = 0;
				Bfs(pos);
				board[y][x] = 1;
			}
		}
	}
	
	if (res == 123456789)
		res = -1;
	cout << res << '\n';

	return 0;
}

결국 모르겠어서 인터넷을 보고 문제를 해결했는데, 나의 코드에서 수정을 해서 다시 풀어보고싶었는데
잘 모르겠다.

아니 다른 사람들은 왜 다 천재처럼 보이는건지
난 아무것도 모르는 말하는 감자인데,,,
열심히 해야지..

위의 코드를 수정해서 정답을 맞히면 다시 이 글을 수정해서 정답 코드를 올려야지.