1부터 N까지 M의 배수합


자연수 N이 입력되면 1부터 N까지의 수 중 M의 배수합을 출력하는 프로그램을 작성하세요.

▣ 입력설명
첫 줄에 자연수 N과 M이 차례대로 입력됩니다.(3<=M<N<=1000)

▣ 출력설명
첫 줄에 M의 배수합을 출력한다.

▣ 입력예제 1 
15 3

▣ 출력예제 1
45 


풀이

int n, m;

void solve()
{
	cin >> n >> m;
	int sum = 0;

	for (int i = 1; i <= n; ++i)
	{
		if (i % m == 0)
		{
			sum += i;
		}
	}

	cout << sum;
}

전체 코드

#define _CRT_SECURE_NO_WARNINGS

#include <stdio.h>
#include <string.h>
#include <ctype.h>
#include<iostream>
#include <fstream>
#include <vector>

using namespace std;

int n, m;

void solve()
{
	cin >> n >> m;
	int sum = 0;

	for (int i = 1; i <= n; ++i)
	{
		if (i % m == 0)
		{
			sum += i;
		}
	}

	cout << sum;
}

int main() 
{
	ios_base::sync_with_stdio(false);
	cin.tie(NULL);
	cout.tie(NULL);
	freopen("input.txt", "rt", stdin);

	solve();

	return 0;
}