🙇‍♀️최소비용(DFS : 가중치 방향그래프 인접리스트)

가중치 방향그래프가 주어지면 1번 정점에서 N번 정점으로 가는 최소비용을 출력하는 프로그램을 작성하세요.

image

▣ 입력설명
첫째 줄에는 정점의 수 N(1<=N<=20)와 간선의 수 M가 주어진다. 

그 다음부터 M줄에 걸쳐 연결정보가 주어진다. 

▣ 출력설명
총 가지수를 출력한다.

▣ 입력예제 1 
5 8
1 2 12
1 3 6
1 4 10
2 3 2
2 5 2
3 4 3
4 2 2
4 5 5

▣ 출력예제 1
13

🚀풀이

그래프를 그리는 방식을 인접행렬에서 인접리스트로 변환시킨다.

이때 비용까지 들어가야하므로 pair<int, int>를 이용했다.

void setting()
{
	cin >> n >> m;
	visited = vector<bool>(n + 1);

	for (int i = 1; i <= m; ++i)
	{
		int a, b, cost;
		cin >> a >> b >> cost;
		board[a].push_back({ b, cost }); // pair를 사용
	}
}

그 후 인접행렬과 마찬가지로 DFS를 돌리는데 방문할 때 비용 계산을하고 방문 취소시 비용도 철회해야한다.

pair의 첫 번째값이 정점 인덱스이고 두 번째값이 비용값이다.

void DFS(int here)
{
	if (here > n)
		return;
	if (here == n)
	{
		minCost = min(minCost, totalCost);
	}

	for (int there = 0; there < board[here].size(); ++there)
	{
		if (visited[board[here][there].first])
			continue;

		visited[board[here][there].first] = true;
		totalCost += board[here][there].second;
		DFS(board[here][there].first);
		visited[board[here][there].first] = false;
		totalCost -= board[here][there].second;
	}
}

🚀전체 코드

#define _CRT_SECURE_NO_WARNINGS

#include <stdio.h>
#include <string.h>
#include <ctype.h>
#include<iostream>
#include <fstream>
#include <vector>
#include <algorithm>

using namespace std;

int n, m, totalCost = 0, minCost = 123456789;
//vector<vector<int>> board;
vector<pair<int, int>> board[100];
vector<bool> visited;

void setting()
{
	cin >> n >> m;
	//board = vector<vector<int>>(n + 1);
	//board = vector<pair<int, int>>(n + 1);
	visited = vector<bool>(n + 1);

	for (int i = 1; i <= m; ++i)
	{
		int a, b, cost;
		cin >> a >> b >> cost;
		board[a].push_back({ b, cost });
		//board[a].back() = cost;
	}
}

void DFS(int here)
{
	if (here > n)
		return;
	if (here == n)
	{
		minCost = min(minCost, totalCost);
	}

	for (int there = 0; there < board[here].size(); ++there)
	{
		if (visited[board[here][there].first])
			continue;

		visited[board[here][there].first] = true;
		totalCost += board[here][there].second;
		DFS(board[here][there].first);
		visited[board[here][there].first] = false;
		totalCost -= board[here][there].second;
	}
}

void solve()
{
	setting();

	DFS(1);

	cout << minCost;
}

int main()
{
	ios_base::sync_with_stdio(false);
	cin.tie(NULL);
	cout.tie(NULL);
	//freopen("input.txt", "rt", stdin);

	solve();

	return 0;
}