🙇‍♀️연속된 자연수의 합

입력으로 양의 정수 N이 입력되면 2개 이상의 연속된 자연수의 합으로 정수 N을 표현하는 방법의 가짓수를 출력하는 프로그램을 작성하세요.
만약 N=15이면
7+8=15
4+5+6=15
1+2+3+4+5=15
와 같이 총 3가지의 경우가 존재한다.

▣ 입력설명
첫 번째 줄에 양의 정수 N(7<=N<1000)이 주어진다.

▣ 출력설명
첫줄부터 각각의 경우의 수를 출력한다.

맨 마지막 줄에 총 개수를 출력한다.

▣ 입력예제 1 
15

▣ 출력예제 1
7 + 8 = 15
4 + 5 + 6 = 15
1 + 2 + 3 + 4 + 5 = 15
3

🚀풀이

int N;

void solve()
{
	cin >> N;

	// 짝수 홀수 판별?
	// 2로 가능한 경우
	// (1+2)+2의 배수
	// (15 - 3) % 2 == 0
	// 이러면 가능
	// 언제까지?
	// (1 + 2 + 3 ...  t) < N

	int c = 0; // 총 경우의 수
	int tc = 2; // 2부터 시작하여 가능한 경우 확인할 계획
	int sum = 0;
	while (sum < N)
	{
		sum = 0;
		for (int i = 1; i <= tc; ++i)
		{
			sum += i;
		}

		if ((N - sum) % tc == 0)
		{
			c++;

			cout << 1 + (N - sum) / tc;
			int j = 2;
			for (int i = 2; i <= tc; ++i)
			{
				cout << "+ " << j + (N - sum) / tc;
				j++;
			}
			cout << " = " << N << endl;
		}
		
		tc++;
	}

	cout << c;
}

🚀전체 코드

#define _CRT_SECURE_NO_WARNINGS

#include <stdio.h>
#include <string.h>
#include <ctype.h>
#include<iostream>
#include <fstream>
#include <vector>
#include <algorithm>

using namespace std;

int N;

void solve()
{
	cin >> N;

	// 짝수 홀수 판별?
	// 2로 가능한 경우
	// (1+2)+2의 배수
	// (15 - 3) % 2 == 0
	// 이러면 가능
	// 언제까지?
	// (1 + 2 + 3 ...  t) < N

	int c = 0; // 총 경우의 수
	int tc = 2; // 2부터 시작하여 가능한 경우 확인할 계획
	int sum = 0;
	while (sum < N)
	{
		sum = 0;
		for (int i = 1; i <= tc; ++i)
		{
			sum += i;
		}

		if ((N - sum) % tc == 0)
		{
			c++;

			cout << 1 + (N - sum) / tc;
			int j = 2;
			for (int i = 2; i <= tc; ++i)
			{
				cout << "+ " << j + (N - sum) / tc;
				j++;
			}
			cout << " = " << N << endl;
		}
		
		tc++;
	}

	cout << c;
}

int main() 
{
	ios_base::sync_with_stdio(false);
	cin.tie(NULL);
	cout.tie(NULL);
	//freopen("input.txt", "rt", stdin);

	solve();

	return 0;
}