🙇‍♀️경로 탐색(DFS)

방향그래프가 주어지면 1번 정점에서 N번 정점으로 가는 모든 경로의 가지 수를 출력하는 프로그램을 작성하세요.

image

아래 그래프에서 1번 정점에서 5번 정점으로 가는 가지 수는
1 2 3 4 5
1 2 5
1 3 4 2 5
1 3 4 5
1 4 2 5
1 4 5
총 6 가지입니다.

▣ 입력설명
첫째 줄에는 정점의 수 N(1<=N<=20)와 간선의 수 M가 주어진다. 

그 다음부터 M줄에 걸쳐 연결정보가 주어진다.

▣ 출력설명
총 가지수를 출력한다.

▣ 입력예제 1 
5 9
1 2 
1 3
1 4 
2 1 
2 3 
2 5 
3 4 
4 2 
4 5 

▣ 출력예제 1
6

🚀풀이

DFS로 완전 탐색을 하면서 문제를 풀어야한다.

중요한 점은 완전 탐색이므로 한번 방문하고 DFS를 돌리고 방문상태를 돌려놔야한다.

아예 방문을 생각안하면 무한루프에 빠진다.

void DFS(int here)
{
	//cout << here << " ";
	if (here == n)
		res++;

	for (int there = 1; there <= n; ++there)
	{
		if (board[here][there] == 0)
			continue;

		if (visited[there] == 0)
		{
			visited[here] = 1; // 방문 등록
			DFS(there);
			visited[here] = 0; // 방문 원복
		}
	}
}

🚀전체 코드

#define _CRT_SECURE_NO_WARNINGS

#include <stdio.h>
#include <string.h>
#include <ctype.h>
#include<iostream>
#include <fstream>
#include <vector>
#include <algorithm>

using namespace std;

int board[21][21];
int n, m, res = 0;
int visited[21];

void setting()
{
	cin >> n >> m;

	for (int i = 1; i <= m; ++i)
	{
		int a, b;
		cin >> a >> b;
		board[a][b] = 1;
	}
}

void DFS(int here)
{
	//cout << here << " ";
	if (here == n)
		res++;

	for (int there = 1; there <= n; ++there)
	{
		if (board[here][there] == 0)
			continue;

		if (visited[there] == 0)
		{
			visited[here] = 1;
			DFS(there);
			visited[here] = 0;
		}
	}
}

void solve()
{
	visited[1] = 1;
	DFS(1);

	cout << res;
}

int main()
{
	ios_base::sync_with_stdio(false);
	cin.tie(NULL);
	cout.tie(NULL);
	//freopen("input.txt", "rt", stdin);

	setting();
	solve();

	return 0;
}